Texas A&M University
Laboratory of Uel Jackson McMahan

EM3D Tutorial
Software for Electron Microscope Tomography

EM3D Version 2.0, July 2011 Edition

Mira Raman, Cornelia Koch-Stoschek, Robert Marshall, David Yip, David Ress, Mark Harlow, Joseph Szule, and U. J. McMahan

© 2011 McMahan Laboratory, Texas A&M University. All rights reserved.
Table of Contents

Preface .......................................................................................................................................6

1 Getting Started..........................................................................................................................7

1.1 An introduction to this text............................................................................................ 7
  1.1.1 Main sections of text............................................................................................. 7
  1.1.2 Syntax of text........................................................................................................ 7

1.2 Some precautions and recommendations ................................................................... 8

1.3 Operational features overview ......................................................................................8
  1.3.1 Import raw EM projections .................................................................................... 8
  1.3.2 Alignment.............................................................................................................. 8
  1.3.3 Reconstruction...................................................................................................... 9
  1.3.4 Combination of dual axis datasets (optional) ....................................................... 9
  1.3.5 Segmentation ....................................................................................................... 9
  1.3.6 Model generation and visualization window ....................................................... 10
  1.3.7 Calculation.......................................................................................................... 10

1.4 EM3D file format and maintenance .............................................................................10

1.5 Downloading EM3D ...................................................................................................... 11

1.6 Installing EM3D ............................................................................................................. 11
  1.6.1 Java.................................................................................................................... 11
  1.6.2 Windows XP or greater....................................................................................... 11
  1.6.3 Mac OS X ........................................................................................................... 13

2 Importing and saving datasets .............................................................................................14

2.1 Load TIFF files, Synthetic data set.............................................................................. 14

2.2 Describe data ................................................................................................................ 14

2.3 Save data in the EM3D format ..................................................................................... 15

3 EM3D visualization window .............................................................................................. 16

3.1 Projection mode........................................................................................................... 16
  3.1.1 Coordinates ......................................................................................................... 16

Using EM3D
3.1.2 Measure distances ................................................................. 16
3.1.3 Projection slider ................................................................. 17
3.1.4 Magnification ................................................................. 17
3.1.5 Scaling ........................................................................... 18
3.1.6 Power Spectrum ......................................................... 19
3.1.7 Tilt series animation ..................................................... 19

4 Alignment .................................................................................. 20

4.1 Open the projection alignment window ........................................ 20
4.2 Fiducial marker contrast-detection parameters .................................. 21
4.3 Automatic alignment ................................................................. 22
  4.3.1 Fine tune alignment ............................................................ 23
  4.3.2 Visually confirm alignment ..................................................... 23
  4.3.3 Trouble shooting automatic alignment ....................................... 23
  4.3.4 Adding or moving individual fiducial markers on a projection ......... 24
4.4 Semi-automatic alignment (Not required for most datasets) ............... 24
  4.4.1 Identify bad projections ........................................................ 25
  4.4.2 Delete bad projections ........................................................ 25
  4.4.3 Acquire fiducials ............................................................... 25
  4.4.4 Indexing Fiducials ............................................................... 25
  4.4.5 Calculating error and refining fiducial positions ....................... 26

5 Reconstruction .............................................................................. 27

5.1 Understand the reason for slab reconstruction .................................. 27
5.2 Open the Reconstruction window .................................................. 27
5.3 Adjust Center and Thickness for dataset ......................................... 28
  5.3.1 Adjust the center and thickness of the volume ......................... 29
  5.3.2 Locate the edges of the volume ............................................. 31
5.4 Full resolution reconstruction ..................................................... 31

6 EM3D visualization window – Volume mode .................................... 33

6.1 Navigating through the Volume .................................................. 33
6.2 Averaging slices ........................................................................................................... 34
6.3 Rotating the Volume ................................................................................................. 34
6.4 Filter ............................................................................................................................... 34
6.5 Core ................................................................................................................................ 35
6.6 Features that work the same in Projection Mode ...................................................... 35
   6.6.1 Magnification ...................................................................................................... 36
   6.6.2 Animation............................................................................................................ 36
   6.6.3 Scaling ................................................................................................................ 36
7 Dual Axis Combine .................................................................................................................37
   7.1 General procedure for aligning and reconstructing dual axis datasets .................. 37
   7.2 About the sample dual axis data ................................................................................. 38
   7.3 Loading the dual dataset ............................................................................................. 38
   7.4 Orienting volume B ....................................................................................................... 38
   7.5 Identifying fiducial pairs (Indexing) ............................................................................ 39
   7.6 Remove invalid pairs and combine ............................................................................. 39
8 Segmentation and Rendering ...............................................................................................42
   8.1 How segmentation works ............................................................................................ 43
   8.2 Segmentation modes ................................................................................................... 46
   8.3 Automatic closed segmentation ................................................................................. 47
     8.3.1 Segmenting the upper right vesicle ................................................................. 47
   8.4 Render the vesicle ........................................................................................................ 51
   8.5 Automatic isolated segmentation .............................................................................. 55
   8.6 Automatic pinned segmentation ............................................................................... 57
   8.7 Render pinned segmentation ...................................................................................... 58
   8.8 Strategies for adjusting automatic segmentations ................................................... 59
     8.8.1 Setting the start/stop slice .................................................................................. 59
     8.8.2 Adjust minimum/maximum gray value ............................................................ 59
     8.8.3 Smoothing .......................................................................................................... 59
     8.8.4 Adjusting the anchor line and re-propagating ..................................................... 59
8.8.5 Using a thinner search width ................................................................. 60

8.9 Manual segmentation .............................................................................. 60

8.10 Rendering a manually segmented object .............................................. 61

8.11 Working with groups and regions ......................................................... 62

8.12 Advanced Rendering ............................................................................. 63

9 Calculations .............................................................................................. 64

9.1 Spatial uncertainty .................................................................................. 64

9.2 Thickness ............................................................................................... 64

9.3 Proximity ............................................................................................... 65

10 Appendix .................................................................................................. 66

10.1 Acknowledgments .................................................................................. 66

10.2 Glossary ............................................................................................... 67

10.3 Acronyms ............................................................................................. 67

10.4 Table of Figures .................................................................................... 68

10.5 Some RGB color combinations ............................................................. 69
EM3D is a multi-platform application designed to align, reconstruct, segment, model, and analyze electron microscope tomography data. EM3D is compatible with Macintosh, and Windows. Each dataset consists of a series of two-dimensional transmission electron microscope (TEM) images recorded on a CCD camera at regular tilt intervals, for instance, ±70º at 1º increments; fiducial markers must be visible on each image to facilitate alignment. EM3D will also load, align, and merge dual axis datasets contain two series of projections taken at perpendicular angles to one another.

EM3D was first developed in the Laboratory of Dr. U. J. McMahan (Professor of Neurobiology and of Structural Biology at Stanford University School of Medici funded by National Institute of Mental Health (MH068065). EM3D software is the joint effort among cellular and molecular biologists, who use it daily, and the computational biologists and engineers who develop it.

EM3D 1.X was developed by Dr. David Ress, David Yip, Cornelia Koch-Stoschek, and Mira Raman in the IDL environment. EM3D 2.X is being developed by David Yip in Java/C++.

This tutorial is designed to instruct a new user in the analysis of EM tomography data using a small synthetic dataset. The tutorial guides the user through the processes of importing the tilt series, aligning the projections, reconstructing the projections into a tomogram, combining dual axis data, segmenting objects of interest, and doing 3D renderings. A manual is available for more in-depth information on how to use EM3D V2.0. Details on acquiring the EM3D application and the Synthetic dataset can be found at http://em3d.org.

EM3D has the typical benefits and liabilities of early software releases. Nevertheless, major efforts are being made on many levels to make this new version of EM3D intuitive, stable, and easy to use. The IDL version of EM3D has been used since 1997 with excellent results in discovering new structures at the 2—3 nm scale, and efforts to improve features and performance continue.

This software is released expressly for Research Purposes Only.
1 Getting Started

All users should read this section before running EM3D for the first time.

1.1 An introduction to this text

1.1.1 Main sections of text

This text is divided into 2 main sections and an Appendix.

1. Getting Started - This section contains all the information necessary to download, install, and run EM3D. It also contains a brief description of the steps used to analyze data from importation to 3D surface rendering.

2. Tutorial - This is a step-by-step introduction to the EM3D software that takes the user through all the steps involved in the successful analysis of TEM data.

3. Appendix – Contains a glossary of terms, acronym list, and a list of figures.

Most of the images in this document are taken from the Windows version of EM3D. The detailed appearance of the graphical user interface varies somewhat from platform-to-platform and can be adjusted using the LF menu item in the Help>LF drop-down in the main visualization window.

WHEN USING THE OS X VERSION, CHANGING THE DEFAULT LF LAYOUT TO JAVA (Help>LF>Java RESOLVES ANY WINDOW SIZING ISSUES.

1.1.2 Syntax of text

Any action you should perform will be bulleted.

• Read this text.

Items in bold refer to elements of the EM3D User Interface, such as menu items, sliders, buttons, etc. . For instance, **Projection Number** slider, **File** menu item

The first time a glossary name is used, it is written in **bold italics**. For instance, **Voxel**.

EM3D and tutorial related definitions are written in italics, such as **State file**, **Binary file**.
1.2 Some precautions and recommendations

Although the synthetic dataset that accompanies this tutorial is designed to simulate real EM data, it does have some different characteristics. For instance, because of the simplicity of the artificial data some objects in the reconstructed volume exhibit unusually prominent reconstruction artifacts. Nevertheless, working through the tutorial with this synthetic data will enable the new user to quickly learn the features of EM3D.

The size of a dataset that can be loaded is dependent on the capabilities of the computer and affects the speed of operation. Here are some tips for dealing with large datasets:

• Decimate the projections when they are initially loaded
• Reconstruct a decimated volume
• After reconstruction, do not load the projections
• Decimate the rendering volume
• Produce a core (subvolume) from the reconstructed volume. (Currently not implemented in the preview release.)

A three-button mouse is required when using EM3D. Set display color quality to “Highest” for PC platforms; on Macintosh, set monitor colors to millions. A single large monitor or dual monitors are recommended to accommodate the many windows used with EM3D.

Slight variations in results have been observed on different platforms.

1.3 Operational features overview

EM3D provides all the process steps necessary for working with EM tomography data.

1.3.1 Import raw EM projections

The starting point for these operations is the raw, unaligned EM projection images (Figure 1).

Note that the images show random spatial offsets from one another.

Figure 1: Raw, unaligned EM projection images

1.3.2 Alignment

Calculate and remove the image-to-image offsets between individual projections using fiducial markers deposited on the sample or contained within the sample. After alignment, the collection of images now appears to tilt along a common axis.
1.3.3 Reconstruction

Filtered back-projection converts the aligned projections into a volumetric reconstruction of the data. The initial EM3D interface to the volume consists of three 2D views corresponding to orthogonal cut planes.

1.3.4 Combination of dual axis datasets (optional)

If two orthogonal sets of projections were collected and reconstructed they are combined in this step into one volume.

1.3.5 Segmentation

Tools are provided to semi-automatically or manually isolate individual structures based on their image grayscale density. This process creates volumes-of-interests (VOIs), each containing a logically distinct structural component (Figure 4).
1.3.6 Model generation and visualization window

A structural model, usually an isodensity surface, can be created from each volume-of-interest (VOI). The models can be visualized in 3D renderings, turned on or off, given different colors and opacities, etc.

![Surface model of a synthetic synaptic vesicle (blue), presynaptic membrane (gray) and two filaments (yellow)](image)

Figure 5: Surface model of a synthetic synaptic vesicle (blue), presynaptic membrane (gray) and two filaments (yellow)

1.3.7 Calculation

The surface models can be analyzed to measure their spatial uncertainty, proximity to neighboring objects, and other quantitative features. The results of these calculations can be visualized as a color map overlaid on the rendered surface models.

1.4 EM3D file format and maintenance

Saved EM3D files consists of two types of files:

1. The State file, distinguished by its ‘.xml’ extension: `<filename>.xml`
2. The Binary file, distinguished by its ‘.data’ extension: `<filename>.data`.

The State file is a relatively small file that contains all the information with respect to the larger Binary file such as projection alignment and segmentation data. The Binary file contains the projection and volume data.

These two files are best kept together in named directories. For example, create a directory called EM to contain all EM data, e.g., /EM, and a subdirectory that corresponds to a single dataset, e.g., /EM/dataset. This directory, in turn, should contain a single Binary file, e.g., `dataset1.data`, and one, or more, State files, e.g., `dataset1.xml, dataset2.xml, dataset3.xml`, etc. By saving changes in the smaller State files, and retaining the larger Binary file, disk space is conserved with successive steps in the process. The Binary file needs only to be saved after a tilt series is reconstructed into a volume, or if the volume is filtered, decimated, or cropped. In the latter case, it is best to create a new directory that, once again contains only a single Binary file and its associated state files.

Using EM3D
Caution: All State files contain a reference to the Binary file from which they were generated; so changing file names outside of EM3D may result in errors.

Do not edit the State file by hand.

To use raw data from the EM, images must first be imported into EM3D and converted to a pair of State and Binary files. Current raw data formats supported by EM3D include sets of individual image files or an MRC stack file.

1.5 Downloading EM3D

The newest release of EM3D is available for download at http://em3d.stanford.edu. For Windows, download the EM3D 2.0.msi file, for Macintosh, download the EM3D 2.0.mac.zip

Please also download datasets.zip (for Mac) or dataset.tar.gz (for Windows). The compressed files contain synthetic projections in TIFF format and a projection stack, Synth.mrc.

These two methods of importing data into EM3D are described in Section 2. There is also an aligned and reconstructed a dual tilt dataset used in this tutorial as sample data.

1.6 Installing EM3D

1.6.1 Java

Java 1.4.2 or higher is needed to run EM3D. If an appropriate version of Java is not installed on your computer, it can be downloaded at http://java.sun.com/javase/downloads/index_jdk5.jsp

If java is not installed on your computer EM3D will NOT run.

Macintosh regularly offers updates for Java or it can be manually updated from the Apple web site.

1.6.2 Windows XP or greater

- Open the Add or Remove Programs application in the Control Panel folder.
- Remove previous version(s) of EM3D.
- Double Click on the em3d.zip file.
- Double click on the em3d.msi file.
- The following setup wizard will appear.
Using EM3D

- Press Next>

Choose the location where you want EM3D to Install.

If more than one user will use EM3D on the computer select Everyone.

- Press Next > on this screen and the next screen.

- EM3D will be installed and can be run from the Window’s Start Menu.

Using EM3D
1.6.3 Mac OS X

- Double-click the Mac EM3D file (em3d 2.0.mac.zip)
- Place the uncompressed icon/application in the Applications folder
- Place an alias in the dock.
2 Importing and saving datasets

Data can be initially imported into EM3d in two ways:

1. Import individual images (JPEG, BMP, GIF, PNM, PNG, AWT, and TIFF-format) or
2. Import a .mrc stack of images typically generated by most data collection software such as FEI Tomography or UCSF Tomo.

Once imported, data is then saved into EM3D format as .xml and .data files.

When EM3D launches, a blank EM3D visualization window opens.

**Note:** Images should be in a 16-bit format.

### 2.1 Load TIFF files, Synthetic data set

The projections of the sample synthetic dataset are in TIFF format. (The dataset can be downloaded from em3d.stanford.edu/downloads.)

- In the EM3D visualization window select **File > Import > Images**.
- Navigate to the `tiff` directory in the `EM3D_datasets` directory.
- Select all of the `synthA_###.tiff` files in the appropriate sequence.

*On Macintosh, select `synthA_000.tiff` with the left mouse button. Scroll to the bottom of the list, hold the `<shift>` key, and select the last file, `synthA_150.tiff`. All files should be highlighted.*

*On Windows platforms it is easiest to use the `<ctrl-A>` (select all) key.*

- Alternatively, you can also import the Synth.mrc stack with **File > Import > MRC**, then select the Synth.mrc file.
- Select **OK**, and the dataset import window will appear (Figure 8).

### 2.2 Describe data

Fill in the **Image Import** fields so they match the values in Figure 8.
Note: If the Twist Angle is not entered, EM3D will calculate it. The alignment will take a little longer for the alignment process to complete.

- Press OK.

The center projection number 75 is displayed in the main EM3D window. First, save the imported projections, then explore the features of this window in the EM3D window – projection mode.

If you chose to import the Synth.mrc stack, the specifications are already in the header, so it’s ready to import.

### 2.3 Save data in the EM3D format

- From the EM3D menu select File>Save>Binary and State. A file browser appears.
- Navigate to the EM3D distribution directory.
- Save the file as synthetic_start. Suffixes will be added automatically

Note: Both the State and Binary files are saved. The binary file only needs to be saved when the initial projections are loaded and after a reconstruction has been performed.
3  EM3D visualization window

3.1  Projection mode

Before we proceed with alignment, we need to learn about the features of the main EM3D window in Projections mode.

The upper-left corner of the EM3D visualization window displays information about the loaded dataset: Study, Source, Magnification, and Pixel size, based on the data’s header information or user-entered information.

![EM3D Visualization Window](image)

**Figure 9: Projections in visualization window**

3.1.1  Coordinates

Move the mouse cursor over the image and the coordinates of the cursor are displayed in the Coordinates (nm) field.

*Note that the coordinates shown are the distance of the mouse from the center of the projection.*

3.1.2  Measure distances

A simple measuring tool is available, but not obvious in the main EM3D window.
To use the measurement tool, right click the mouse button at the starting point and drag the mouse. The distance in nm from the starting point to the mouse’s current location will be displayed in the **Distance(nm)** field, directly below the **Coordinates(nm)**. 

*Note: The measurement is not stored and disappears when the mouse button is released.*

![EM3D 2.0 interface](image)

**Figure 10: Measuring tool**

### 3.1.3 Projection slider

The **Projection** slider defaults to the projection that corresponds to the zero-tilt projection, in this case “75”.

- Scroll through the projections by using the **Projection** slider to determine if any projections should be deleted (poor focus, a blank image, etc).
- Return to projection 75 by clicking the **Center** button.

### 3.1.4 Magnification

The size of the displayed image can be controlled using the zoom **list** at the lower left corner of the window.

- Enlarge the display to 150%.
Note that the image window gets horizontal and vertical scroll bars that allow navigation through the entire image.

- Use the **Home** button to return to the original resolution.

### 3.1.5 Scaling

**Image scaling** is used to set which part of a linear contrast range visually best suits the data, e.g., for better fiducial acquisition with noisy data or to better view images during segmentation. Scaling changes the visible gray scale range based on the cumulative distribution function (**CDF**), which is shown as a plot versus gray value.

- To open the **Image Scaling** window, select **Image > Scaling** from the main menu bar.

![Image Scaling](image.png)

*Figure 11: Image Scaling*

The red line is the CDF of the image. If **Absolute** is selected it is the CDF of all of the projections combined; whereas, if **Relative** is selected it represents the CDF for the projection currently displayed in the **EM3D** visualization window.

The **Min Clip** and **Max Clip** are represented in the graph as the 2 blue lines. Any pixel that has a gray value less than the first blue line will be displayed in the **EM3D** window as black, and any pixel with a gray value higher than the second blue line will be displayed as white. Thus all the contrast that is shown in the EM3D window is assigned to the values between the two blue lines.

For example, if **Max Clip** is set to .99 then all of the pixels that have gray values in the highest 1% will be shown in white. If **Max Clip** is set to .85 then the highest 15% of the pixels will be displayed in white. Conversely the pixels below **Min Clip** will be displayed black. The **Invert** button reverses the displayed grayscale, generating a negative image that is often useful for segmentation.

Note that the values are only inverted in the display, and not inverted in any of the calculations, nor in the **CDF** used to select the contrast range (displayed above in red).
3.1.6 Power Spectrum

**Image > Power Spectrum** to view a projection’s power spectrum. This is particularly useful to determine the suitability of any projection before aligning the data set. To scale the spectrum, use the **Image > Scaling** window as described above. Spectra can also be reviewed similar to projections by using the **Image > Review** feature described in 3.1.7.

3.1.7 Tilt series animation

**Image > Review** creates a movie by scrolling through projections or slices in the **EM3D** visualization window. The movie’s parameters are defined in the **Review** control (Figure 12).

![Review Control](image)

*Figure 12: Review Control*

- The **Start Projection** and **Stop Projection** determine, which projections are used to make the movie.
- **Play Start Projection** and **Play Stop Projection** determine the range of slices that are shown on the screen, when **Review** is pressed.
- **Frames Per Second** is used to control the speed of the playback after the movie is generated.
- **Increment** is a way to reduce the amount of memory needed to create the movie, by only showing every other projection or every third projection, the size of memory needed is reduced.
- If **Bounce** is selected the movie loop will play from front to back, then back to front, showing a smooth transition. If **Bounce** is not selected the movie will loop from the last frame back to the first frame.
- **Save** will save the pictures exactly as they appear in the movie to JPEG format image files.
4 Alignment

The raw EM projections are not aligned. Before reconstructing the volume, the image-to-image offsets between individual projections must be determined. This is accomplished by identifying and aligning **fiducial markers** that were either deposited on the sample (such as gold-labeled antibodies) or contained within the sample itself.

EM3D looks for high density fiducial markers for automatic alignment, so additional features can interfere with locating these markers and can give erroneous alignments.

*For instance, blank pixel borders surrounding the CCD window, micron marker measurements showing on the images, etc. interfere with EM3D’s ability to locate alignment fiducials.*

**Summary:**

1. Open the Alignment window.
2. Adjust the fiducial marker contrast parameters.
3. Perform either Automatic or Semi-automatic alignment.
4. Refine the alignment to reach the smallest residual error.

4.1 Open the projection alignment window

*Figure 13: Projection Alignment window*

- From the EM3D visualization window, select **Process > Align…** to open the Projection Alignment window (Figure 13).
4.2 Fiducial marker contrast-detection parameters

In this step we are going to set the parameters to locate all potential fiducial markers. Once we have decided on the parameter values, the program identifies all possible fiducial markers throughout the projections.

• Press the **Display Markers button** at the button of the **Alignment** window.

  The main **EM3D** visualization window will display the projections with a yellow overlay that indicates the likely positions of fiducial markers.

![Figure 14: Display Markers with Threshold set at an appropriate value of 0.35 (left) and too high a value of 0.50 (right)](image)

• Adjust the acquisition parameters so that the majority of the fiducial markers visible on the zero-tilt image are marked with the yellow overlay.

  Adjustments can be made by either typing in the text fields (and pressing Enter) or by moving the sliders.

  Please read the reference manual for information about choosing parameters.

Recommended settings for the Synthetic dataset are

- **Fiducial Diameter**: 5.0 nm
- **Twist Angle**: 5.0 (generated by the microscope during acquisition)
- **Threshold**: 0.35
- **Min. Projections**: 37 (minimum number of projections on which a fiducial Indexes to keep during Automatic Alignment)

• After setting the parameters press **Display Markers** to turn off the overlay in order to increase the speed of the following steps.

The **Twist Angle** is the rotation of the projection tilt axis about the depth axis. When the projections are aligned, the tilt axis will be oriented vertically, parallel to the $y$-axis of the visualization window display.

• If you know the proper twist angle and don’t want the program to adjust it, lock it by left clicking on the **Twist Angle** label.

  A little lock symbol will be displayed next to twist angle, see Figure 15.
4.3 Automatic alignment

- Press **Automatic** in the **Alignment** window.

  *This is the easiest way to align the projections.*

**Automatic** performs all of the steps required for alignment.

1. **Automatic** first identifies possible fiducial marker on each projection (**Acquire**).

2. Then **Automatic** finds the correspondence between potential fiducial marker throughout the dataset (**Index**).

3. Finally **Automatic** iteratively calculates the residual errors for each fiducial marker and **Deletes** the fiducial marker with the highest error.

![Figure 16: Alignment after using automatic alignment](image)

**Note that the fiducial marker used for the alignment are marked by yellow ‘*’ symbols with a red numeral.**

In the Alignment window you find the fiducial marker numbers and their positions, the number of projections on which they occur and the error. The total error of the automatic alignment for the Synthetic dataset is 0.15 (in pixels).

**In general, the goal is to obtain an alignment where the total RMS error is <1.0 pixel for every 512 pixels of dimension, so for a 1024x1024 image we strive for an error <2.0.**
4.3.1 Fine tune alignment

In order to fine tune the alignment,

• Unlock the twist angle by pressing the left mouse button over the **Twist Angle** label.
• Then press the **Calculate** button.

The twist angle will be recalculated and the alignment refined.

![Alignment window with Twist Angle adjusted to 5.4 degrees and Total Error reduced considerably](image)

Notice that the **Twist Angle** adjusted to 5.4 degrees and the **Total Error** was reduced considerably after unlocking the Twist Angle.

**Figure 17: Results of refined Automatic Alignment**

4.3.2 Visually confirm alignment

• Press **Image > Review** in the EM3D visualization window.

If the alignment is good, all the fiducial markers should move smoothly in a horizontal line. (If the alignment is not acceptable please see section 4.3.3.)

Note: Make sure to watch fiducial marker and not the edges of the projections. One suggestion for confirming the alignment is to place the edge of a sheet a paper against the screen below a specific fiducial marker, and press Review. The fiducial marker should appear to roll smoothly along the paper’s edge, not bounce around.

When satisfied with the alignment close the **Alignment** window and save the dataset as “*synthetic_aligned.xml*” by pressing **File > Save > Binary and State**. The suffixes .xml and .data will be added automatically.

The next section on **Trouble shooting automatic alignment** is optional, but may prove very useful with real data.

4.3.3 Trouble shooting automatic alignment

A common cause of automatic alignment failure or the application to locate a nearby fiducial. To resolve this problem,

• check **Edit > Override** in the **Alignment Window**.
• Then press **Index** to use a different algorithm for tracking fiducials through the projections.

• Press **Automatic** to run the alignment algorithm in a modified way. If this yields a good alignment close the **Alignment** window and save the data.

Another common cause of alignment failure is the software’s inability to define a minimum of two fiducials in each projection. Projections not marked are noted in the window at the lower right portion of the alignment window. Go to the failed projection and move to the next projection with at least two fiducials and note what is missing. Turn on the **Display Markers** button and adjust the **Fiducial Size and Threshold** sliders that control the fiducial parameters so the missing fiducials are marked in yellow. When all fiducials are found, press **Calculate** to determine total alignment error. If many projections are missing fiducials, it’s best to begin again. Adjust the **Fiducial Size and Threshold** so more fiducials are marked, turn off the **Display Markers** and then press the **Acquire** button. This will re-identify all possible fiducial markers. A message will ask if you want to clear the previous alignment. After the new fiducial markers have been acquired, repeat the steps for **Automatic Alignment**.

If Override and/or adjusting alignment parameters do not yield a satisfactory alignment then it is necessary to do **semi-automatic alignment**.

### 4.3.4 Adding or moving individual fiducial markers on a projection

**To add or move a fiducial marker** –

• Highlight the fiducial in the **Alignment list**.

  *That fiducial’s marker will turn green on the Projections.*

• Press the **Middle** mouse button where you want the fiducial marker to be. If the fiducial marker does not move to where you want it, turn on the **Display Markers**, and adjust the fiducial parameters, until a small yellow region appears where you want the fiducial marker. Repress the **Middle** mouse button.

• **To remove a fiducial marker** – Press the **right** mouse button on or near the fiducial marker you want to remove.

  *Note: The fiducial marker closest to the mouse click is removed, NOT necessarily the fiducial marker that is highlighted.*

### 4.4 Semi-automatic alignment (Not required for most datasets)

This section should be skipped for the synthetic data. Semi-automatic alignment consists of basically the same series of steps that Automatic alignment uses, but it allows more user interaction. The series of steps for Semi-automatic alignment are:
1. Identify and remove bad projections.

2. Acquire – Identify potential fiducial markers

3. Index – Find correspondence between the identified fiducial markers

4. Manually add/adjust/remove fiducial markers – Some projections may be out of focus so the same parameters that worked for identifying fiducial markers on ‘in focus’ projections don’t work. You may need to identify the fiducial markers by hand on those slices, using different fiducial parameters.

5. Calculate – The error associated with each fiducial marker

6. Delete – Remove fiducial markers from the alignment that have high error or are not present on a large number of projections

7. Refine – Repeat the Calculate and Delete steps until an acceptable alignment is obtained.

4.4.1 Identify bad projections

- Scroll through the projections slider in the EM3D window. If any are out of focus, blank, or in anyway unuseable delete them.

4.4.2 Delete bad projections

- Set the Projection slider to the bad projection.
- From the File menu select Delete Projection.
- Repeat for all bad projections.
- Once all bad projections have been deleted press Compute CDF.

| This step is extremely important. |
| Re-save the binary and state data. |

4.4.3 Acquire fiducials

- Press the Acquire button in the Alignment window.

| If the algorithm is unable to find at least 2 fiducials on any projection it will fail for that projection, and you must either add the fiducials by hand (see section 4.3.4) or adjust the threshold and/or diameter parameters and re-acquire. |

4.4.4 Indexing Fiducials

This is the process of identifying, or tracking, the same fiducial in multiple projections.

- Press Index.

| Note, this option is only available if at least 2 fiducials have been acquired on all projections. |

- If indexing fails, press Override on the Edit menu, followed by Index again.
4.4.5 Calculating error and refining fiducial positions

- Press the **Calculate** button.

- Sort the fiducial errors in descending order by pressing the **Error** column label twice in the **Alignment** window.

- Select fiducials with high error and press **Delete**.
  
  *Note, you must leave at least 2 fiducials on all projections, so if you delete a fiducial it may reduce the number of fiducials left on some projections to less than two. In this case you should either press Undo under the Edit menu, or identify by hand a more accurate fiducial on the projections that have been left with less than 2 fiducials.*

- Press **Calculate**.

Reconstruction and subsequent segmentations are only as good as the alignment. Extra time and effort used for a good, sub-pixel alignment is well rewarded in the segmentation and rendering steps.
5 Reconstruction

After successfully aligning the projections we are ready to reconstruct them into a 3-dimensional volume.

Summary:

1. Understand the reason for slab reconstruction.
2. Open the Reconstruction window.
3. Perform a fast, decimation reconstruction in order to determine the appropriate Center and Thickness.
4. Perform a full-resolution reconstruction.
5. Save EM3D data.

5.1 Understand the reason for slab reconstruction

There are several things to consider before reconstructing the volume. A tilt-series with projection dimensions of 1024x1024 pixels can yield a full size reconstructed volume with dimensions of 1024x1024x1024 pixels. We know the thickness of our sample is always substantially smaller than the width of the projections. In order to reduce the memory and time needed to perform the reconstruction, we will only reconstruct a slab of the volume that contains useful data. Because the synthetic dataset is small, we can generate a full size (256x256x256 pixels) reconstruction to demonstrate the selection of a useful slab of data.

In Figure 18 we see a series of slices through the volume. The fiducial markers that rest on the top and bottom of the sample are visible on slices 75 and 180 respectively; whereas, slices 40 and 216 only contain noise. Thus reconstructing only the slices between the fiducial markers will greatly reduce the amount of time and memory used.

![Figure 18: XY display of slices 40, 75, 110, 128, 149, 180, 216](image)

The following is one method to quickly select the appropriate slices for reconstruction.

**Note:** If doing a dual axis reconstruction, the fiducial markers must be included in both reconstructed volumes.

5.2 Open the Reconstruction window

- Select Process > Reconstruct from the EM3D visualization window.

Using EM3D
The Reconstruction window opens (see Figure 19). The initial **Center** corresponds to $\frac{1}{2}$ the number of pixels in the projections. The initial **Thickness** corresponds to $\frac{1}{4}$ the number of pixels in the projections, and for large datasets, this should represent enough slices to cover the entire volume.

![Reconstruction window](image)

**Figure 19: Default Reconstruction window**

### 5.3 Adjust Center and Thickness for dataset

Our goal in this section is to determine the upper and lower slice limits for reconstructing.

**Note:** *The Set Start Slice and Set Stop Slice buttons are inactive.*

For this purpose a low resolution reconstruction is sufficient.

- Leave the **Center** and **Thickness** at their default values.
- Move the **Decimate** slider to 2.

This will decrease the size of the volume by a factor of 2 in each dimension. For the Synthetic dataset, very little decimation is needed, and a 2:1 decimation will adequately reduce time.

- Move the **Sharpness** slider to 1.

These parameters will yield a volume in the Synthetic data set of 128x128x32 pixels (i.e. $\frac{1}{2}$ of 256x256x64 pixels).

**Note:** *For a decimated reconstruction, the Sharpness slider should be set to 1, and then returned to 4 or higher for the final reconstruction.*

- Select the **Reconstruct** button at the bottom left and a Status window opens to display the progress of the calculation.

The visualization window will display the 3 orthogonal center slices of the reconstruction as it builds up each projection (Figure 20). In addition the parameters listed in the upper left of the visualization window will show a pixel size of 2.0nm and dimensions of 128x128 pixels after the reconstruction.

---

**Using EM3D**

28
The reconstruction can be stopped at anytime by pressing the **Cancel** button, yielding a partial reconstruction. Partial reconstructions exhibit substantial artifacts, but they are often satisfactory for determining the desired thickness of the reconstruction, and they save time.

In addition to the original (x, y) window, the EM3D visualization window displays two additional windows, the (x, z) at the bottom and (z, y) on the left. Note that the blue cross hairs are active in all windows. Use the left mouse button to ‘slice’ through one of the windows and notice how the other windows respond. You can also select the **Slice** slider button and scroll through the volume using the left and right keyboard arrows. These tools are used extensively in segmenting objects in the volume. Turn the crosshairs off or on with Image > Show > Crosshairs.

### 5.3.1 Adjust the center and thickness of the volume

**Note:** Changes to the **Thickness** and **Center** will only take effect after the Reconstruct button has been pressed.

The reconstruction using the default **Thickness** of 64 is too thin because it does not reconstruct all the way out to the fiducial markers (in real data the default is usually sufficient to cover the entire volume).

- Move the **Thickness** slider to 130 and perform a second reconstruction, leaving the **Decimation** slider at 2.
Figure 21: Reconstruction control for thick, decimated volume

Figure 21 shows that after the initial reconstruction, the Set Start and Set Stop Slice buttons are now active. The reconstructed volume contains all the structures but also extends beyond the fiducial markers on the surface (Figure 22).

Figure 22: Thick, decimated reconstruction
5.3.2 Locate the edges of the volume

- Using the Slice slider button in the main window (or use the left mouse button) move the blue horizontal cross hair in the x,z window to the new lower volume edge begins.
- Select the Set Start Slice button in the Reconstruction window.
- Do the same for the upper edge of the volume and select the Set Slice Stop button.
- Then select Reconstruct.

The new reconstruction will appear in the visualization window, based on the parameters set. To adjust volume thickness, repeat the procedure until the desired upper and lower limits are established.

*Dual axis datasets require the inclusion of all fiducial markers in the two reconstructed volumes in order to combine properly.*

*Dual axis volumes must both be the same size.*

![Reconstruction Control after adjusting center and thickness](image)

When satisfied with the volume thickness, generate a full resolution volume.

5.4 Full resolution reconstruction

- Set Decimation to 1.
- Return Sharpness to 4.
- Press Reconstruct.

When satisfied with this reconstructed volume, name and save both the State and Binary files.

- In the EM3D window click on File > Save > Binary and State.
- Save files as synthetic_recon.

Using EM3D
The reconstructed volume will be automatically saved as `synthetic_recon.xml` and `synthetic_recon.data`. These new files will be used in the remainder of the tutorial.

In the future when you load the dataset, you can load just the volume by un-clicking **Load Projections** on the **File** menu before Opening the dataset.
6 EM3D visualization window – Volume mode

The EM3D visualization window operates in two modes, Projections and Volume. Until reconstruction is complete, only Projections mode has been available. However, once reconstruction is complete, Volume mode becomes available. The mode display is controlled by a pair of radio buttons to the right of the Averaging slider. Projections mode is used to view individual EM projection images; when a dataset is initially imported, only this mode is available. Since the dataset is now reconstructed, both Volume and Projections mode are available.

In Volume mode the EM3D visualization window display adds 2 additional graphics panels. This allows you to see cuts through the volume at perpendicular (orthogonal) slices (Figure 24). By default, the middle slice (slice 50) is displayed in the main (x, y) display panel, while the panel to the left shows the (z, y) plane and the panel below shows the (x, z) plane.

6.1 Navigating through the Volume

- The blue crosshairs indicate the relative positions of the different slices within the volume. The crosshairs can be turned on/off by selecting Image > Show > Crosshairs. The crosshairs provide a perspective of objects’ relative positions within the volume, and they are useful for finding edges of objects during segmentation.
• Navigate through the volume display using the **left mouse button**: clicking on the \((x, y)\) display moves the transverse \((x, z)\) and \((z, y)\) displays. Similarly, clicking on either of the transverse displays changes the slice number of the \((x, y)\) display.

• The \((x, y)\) slice can also be changed using the **Slice** slider. Display several other slices of the volume using the **Slice slider**. Click on the **Center** button to go back to the slice 50.

• It is possible to turn on/off the transverse displays by selecting **Image > Show > Transverse**.

### 6.2 Averaging slices

Averaging allows the selection of a different number of adjacent volume slices to be combined (the gray value at each \(x, y\) pixel is averaged with the gray values in adjacent slices at that same \(x, y\) pixel location) and displayed as the current slice image.

• Set the **Averaging** slider to 5.

The average gray scale of slices 48 to 52 is displayed in the \((x, y)\) display.

Averaging is only performed in the \((x,y)\) display.

• Set the **Averaging** slider back to 1.

### 6.3 Rotating the Volume

Virtual slices can be formed at any angle through the volume. The rotation sliders allow the user to adjust the view in order to see stained objects with better contrast, which is particularly important during segmentation. Rotate the volume using the 3 sliders and observe the images.

• The **X Axis** is perpendicular to the \((z, y)\) display, positive rotation is clockwise.

• The **Y Axis** is perpendicular to the \((x, z)\) display, positive rotation is clockwise.

• The **Z Axis** is perpendicular to the main \((x, y)\) display, positive rotation is counter-clockwise.

The cursor position is shown in nm coordinates in the Information in the upper left of the visualization window.

### 6.4 Filter

Filtering smoothes (blurs) the data in the image and removes noise.

• **Process > Filter > Average**
To revert to the original image select **Process > Filter > Reset**. To keep the filtered image select **Process > Filter > Commit**. This will actually replace the volume in memory, and the only way to get the original volume back is to reload the dataset.

*For the tutorial we want to reset the filtered image back to the original.*

### 6.5 Core

Coring is a way to create a smaller dataset that has only the features of interest. This is very important when your volume is large but the area of interest is small. By coring you will reduce the amount of memory needed to store the volume.

- **Process > Core**.

The following dialog appears.

![Core control](image)

*Figure 26: Core control.*

There are 2 ways to select the region to core. First set the slider bars in the control to the region of interest. The other way is to use the right mouse button to draw a region of interest in the x,y display. For this tutorial we do NOT want to core the volume, so just close the dialog by pressing **Cancel**.

### 6.6 Features that work the same in Projection Mode

The following features work the same in volume mode as they do for projection mode.
6.6.1 Magnification

6.6.2 Animation

6.6.3 Scaling
7 Dual Axis Combine

7.1 General procedure for aligning and reconstructing dual axis datasets

The previous sections of this tutorial illustrated the reconstruction of a single axis dataset. When working with dual axis datasets, you will usually start with 2 MRC files containing 2 sets of projections. These projections have first to be aligned and reconstructed individually. Then the 2 resulting volumes can be combined to 1 volume.

To load a dual axis dataset first check the Dual Axis item in the File menu of the visualization window. Next import the data; you will be prompted twice to select the filename of the first axis dataset and second axis dataset.

The most accurate dual axis alignments are obtained when fiducial markers are on both sides of the section or dispursed throughout the section, as with antibody staining methods.

After a successful import open the Alignment window. A toggle appears for changing between set A (first dataset) and set B (second dataset).

- Select Set A.
- Follow the alignment procedure for the first set of projections.
- Select Set B.
- Scroll through the projections to ensure that they are all good and Delete any that are unuseable.

If you Delete any projections make sure to re-calculate the CDF before aligning.

- Align the second set of projectons in the same manner.
- Save the aligned datasets.
- Open the Reconstruction window.
- Check Set A.
- Perform a reconstruction of A.
- Save the Binary and State files.
- Toggle to Set B.
- Reconstruct set B.

It is Mandatory that Set A and Set B have the same dimensions in all 3 axis.

- Save the Binary and State files.
7.2 About the sample dual axis data

The previous sections of this tutorial illustrated the reconstruction of a single axis dataset. The sample dual axis data (part of the downloadable datasets) is a highly decimated real dataset acquired by the McMahan Laboratory. The original projections were acquired at 2048x2048 pixels per projection, and have been decimated by a factor of 8 down to 256x256 pixels per projection, resulting in substantial blurring of the images.

7.3 Loading the dual dataset

- Close and reopen EM3D.
- File > Open.
- Select dual_volumes.xml

7.4 Orienting volume B

- Select Process > Dual Combine…

The Set buttons indicate which volume is being displayed in the EM3D visualization window. By toggling between the buttons you can navigate from volume A to volume B.

The first step in combining the volumes is to get them in roughly the same orientation. This is accomplished by rotating volume B by 90 degrees. Adjacent to the Set buttons is the Rotate B check box.
- Press Rotate B.

Volume B can be rotated by either 90 degrees clockwise or counter-clockwise. You can choose which direction it rotates through the Rotate menu. Confirm that the volumes are in roughly the same orientation by toggling between Set A and B.
7.5 Identifying fiducial pairs (Indexing)

Once the volumes are in the same orientation,

• select Set A.
• Press the Auto Index button in the lower right of the Dual Combine window.

Five columns will appear in the panel, the fiducial number in volume A, the slice on which it occurs, the fiducial number in volume B, the slice in volume B where it occurs, and the distance between the fiducial markers after an initial match of the volumes.

In Figure 28 the second row indicates that Fiducial 1 in volume A is centered on slice 22, while the same fiducial marker in volume B is labeled number 16 and is centered on slice 24. After an initial cross correlation the fiducial marker is displaced by 2.112nm between the 2 volumes.

![Dual Combine Interface](image)

**Figure 28: Auto Indexed**

7.6 Remove invalid pairs and combine

We want to maximize our knowledge of the volume warping by using as many valid fiducial pairs as possible. For the same reasons, we want to eliminate all false fiducial pairs. Real fiducial markers will appear on the top and/or bottom of the sample and not in the middle. The picture on the left of Figure 29 shows 2 examples of incorrectly identified fiducial markers (notice these are in the center of the sample’s thickness), while the picture on the right of Figure 29 shows correctly identified fiducial markers on the bottom of the sample. This dataset only has fiducial markers on the bottom of the sample.
The simplest way to remove pairs not on the surface is to sort the fiducial list based on the **A Slice** position (Figure 30).

- Press the label of the second column to sort the data by **A Slice** (Figure 30).

Now look through the volume in the visualization window and determine the slice where the fiducial markers end (approximately slice 31).

- Scroll down the list and highlight all of the fiducial markers with slice positions in set A above 31.
- Press **Delete**.
- Press **Calculate** to regenerate the least squares alignment of the 2 volumes.
- Double click on the **Distance** tab to sort the distances in descending order (Figure 31).
Notice that the top fiducial marker has a much higher distance, indicating a mis-pairing of the fiducial markers between set A and B.

Figure 31: Sorted by reverse distance

- **Delete** the top fiducial marker in the list.
- Press **Calculate**.
- Repeat this step until satisfied that inappropriate pairs have been eliminated.
- Press **Combine** to create the volume.
- Close the **Dual Combine** window and **Save** both the binary and state data.
8 Segmentation and Rendering

As detailed as the previous seven sections are, loading data, aligning, and reconstructing a new data set comprises about 5% of the effort required by EM3D to extract structures of biological interest. A good alignment and quality reconstruction should take less than an hour depending on the ease of the alignment step.

Segmentating individual structures in the reconstructed volume is based on the stain/grayscale densities of the various objects. Users are free to define, that is, ‘carve out’ volumes of interest (VOIs) based on these grayscales, generating results that are subjective, in nature. Each VOI should contain a distinct, structural component and using automatic, semi-automatic or manual segmentation methods, structures of interest can be isolated from the data set volume. Because biological structures often have a range of grayscale staining, the user determines and limits the range within the VOI to best represent the structure.

Each segmented object is then the basis for a surface model, which can be displayed, measured, and manipulated in 3D.

EM3D provides tools to measure the accuracy of segmentations (Uncertainty) as well as an optimization tool to best represent the segmented structures.

All segmentations are performed in EM3D’s main visualization X, Y window. The image in the main window can be rotated using the X, Y, and/or Z Axis sliders in order to better orient each object for segmentation.

Please load the reconstructed synthetic dataset for this portion of the tutorial.

Summary:

1. Identify a structural component to segment.
2. Find the central slice of the structural component.
3. Select a New object.
4. Name the object.
5. Select the type of segmentation – Manual or Automatic. If Automatic, choose Closed, Isolated, or Pinned.
6. Segment the slice, either automatically or manually.
7. Propagate the segmentation throughout the volume, either automatically or manually.

All Segmentations will vary based on the anchor points chosen with the mouse, for this reason, your segmentations may vary slightly from the ones in the tutorial.

Note: Some users invert the objects’ images in the main visualization window in order to see the objects for segmentation (File>Scaling>Invert check box). For instance,
**8.1 How segmentation works**

The way rendering handles manual and automatic objects is very similar.
Once you know what object you want to segment you need to describe it for the computer.

The first step in doing this is to draw a line that roughly follows the contours of the object. This done by pressing the middle mouse button to add points and the right mouse button to remove points.

---

The line you draw does not need to be perfect, but it should be fairly centered in the object for segmenting.

---

When the Search button is pressed EM3D finds the gray scale range within the width around the line you drew in the previous step. It then sets the minimum and maximum gray value sliders to reasonable values, and highlights any voxel within that range in red.

---

By using the Minimum and Maximum grayscale sliders and the Surface width slider you can determine which voxels will be used to create the anchor lines. Anchor lines are what EM3D uses to represent automatic objects on each slice.

The initial anchor line will be calculated when you press Segment.

---

It is often helpful to reduce both the minimum and the maximum sliders, and to select a width that is less than the actual width of the object.
When you press **Segment** the yellow line with the points you selected is replaced with a green line. The green line is the first anchor line. It is generated by finding the best fit of the red voxels. This is why the previous step is so important.

Now that you have described the basic properties of your object on one slice, EM3D can follow your initial anchor line through subsequent slices by pressing the **Propagate** button.

Once the anchor lines are created they are used to create a mask of the volume, and only values within a radius of the anchor lines will be considered when calculating an isosurface.

Once the object has been propagated the red voxels to the right no longer represent values within the gray scale range, but they represent the surface width. Increase the surface width so that it covers the entire object, so all appropriate voxels will be considered when creating the final surface.

Once the object is defined by creating the anchors and setting the width, the object can be segmented. This is done in the Rendering window.

Select the object from the object list and press Enable. An initial iso-surface will be created that probably does not represent the data well, as you can see from the orange lines in the image.

In order to improve the surface move the Isosurface level slider closer to the foot of the CDF, see Figure 40.
8.2 Segmentation modes

Because the natures of structures observed by EM tomography vary widely, EM3D offers an assortment of ways to segment each object. All object descriptions here refer to the 2D shape in the (x, y) display.

There are two classes of segmentation available in EM3D, automatic and manual.
Automatic segmentation requires the user to define an object on a single slice of the volume, than the program finds logical extensions of the object on subsequent slices.

Manual segmentation is required for any object that is too complex for the automatic segmentation to follow, so the user must define the object on each slice.

Below are 3 distinct sub-classes of Automatic segmentation:

- Closed – Used for objects that are topologically closed, such as the cross section of a sphere.
- Isolated – Used for most ‘open-ended’ objects. The drawback to Isolated segmentation is that the algorithm used for propagating an isolated object often contracts the anchor line as it propagates.
- Pinned – Used for ‘open-ended’ objects that have endpoints that occur in the same X, Y position in each slice, such as a cell membrane that stretches from one edge of the volume to another edge.

### 8.3 Automatic closed segmentation

The four spherical membranes are designed to simulate synaptic vesicles or similar closed structures. Closed segmentation is the appropriate method to use for these objects because they can be fit by a closed polygon and do not vary substantially from slice to slice.

- Open the Segmentation window by selecting **Process > Segment…** from the EM3D visualization window.

![Figure 41: Segmentation Window](image)

#### 8.3.1 Segmenting the upper right vesicle

- Select **Objects -> New object.**
A default object name appears, such as Object 1, in the name field.
- Double click **Object 1** and change the name to **Vesicle 1**.

  \[\textit{Note: All new segmentations default to the Automatic, Closed type.}\]

- In the visualization window navigate to slice 67 by pressing the **Home** button.
- Use **Zoom** on the EM3D visualization window to enlarge the image by 250%.
- Use the sliders to navigate through the visualization window, so the upper right vesicle is roughly centered in the display.
- Press the left mouse button in the center of the vesicle, so that the transverse slices also depict the vesicle (Figure 43).
- Using the middle mouse button, select several points within the vesicle membrane to create a rough anchor path for the vesicle (Figure 43).

  \[\textit{To remove an anchor point press the right mouse button over it.}\]
Using EM3D

Figure 43: Initial segmentation anchor

Note: Reduce or increase the size of the anchor points by using the down or up buttons on the Anchor Size window:

Figure 44: Anchor size adjustment.

All segmentations of the same object will vary slightly, due to the selection of the anchor points.

- When finished setting the Anchor Points, press Search

Notice that the area around the yellow anchor line fills with red (Figure 45b), and the Minimum gray value and Maximum gray value sliders in the Segmentation window adjust.

Reduce the Maximum gray value slider to a value of 670 (Figure 45c) and press Segment (Figure 45d.).

Note: All numbers are rough guides, since segmentations will vary based on anchor points.
Figure 45: Outlined, Searched area, Reduced Maximum Gray value, and segmented center slice of Vesicle 1.

9. Press Propagate to segment the remaining slices in the vesicle.

10. Press the Home button to return the Zoom to 100%, in order to see the segmentation in all 3 windows.

11. Left click inside the segmented vesicle in order to center that vesicle in the transverse displays.

Figure 46: Initial propagated segmentation of vesicle.

6. From the 2 transverse views we see that the propagation worked well for most of the vesicle, but needs some adjustment at the top and bottom slices.

Note: Your propagation may not look the same depending on the initial points chosen.

Figure 47: Propagated segmentation with artifact-induced error (left) and after adjustment (right).
7. Adjust the propagated segmentation to correct this problem. Use the navigation controls in the visualization window to find the slice where the vesicle ends, which should be around slice 99. Now, press the Set Stop button on the Segmentation control window.

Finally, adjust the Surface width slider until the entire structural component is enclosed (approximately 13). If possible, the surface width should always be set generously so that the entire object is enclosed by the VOI. This permits accurate generation of surface models, discussed in the next Section.

To change Min and Max gray values after Segment, return to the Search button and make slider adjustments, then Segment. To change the gray levels after an object is propagated, go to the Objects> Re-anchor tab or select ^R keys with the Segmentation window open.

8.4 Render the vesicle

1. In the EM3D visualization window select Process > Render….

![Process menu on EM3D visualization window Menu](image)

Figure 48: Process menu on EM3D visualization window Menu

The Rendering window opens (Figure 49).
Notice that Vesicle 1 is listed in red.

2. Select Vesicle 1 in the Objects list.

3. Press the Enable button.
When a newly segmented object is first **enabled or the isosurface setting is out of range**, the following message will appear:

![Warning]

This is because there is initially no isosurface level calculated and a default level will be established. Select **OK** and the object will be rendered. When the object is saved, the window will no longer appear when the object is enabled.

![Initial rendering of Vesicle 1]

In addition to displaying the isosurface in the Rendering window, the isosurface is also shown in the EM3D visualization window.

*Notice that the red segmentation line that delimits the segmentation is replaced with the actual isosurface, but that the segmentation anchor line remains.*

To review the objects’ segmentation quality, use mouse buttons for the following:

- **Left Mouse button** - Rotate objects.
- **Middle mouse button** - Zoom in or out in the Z direction (move upward or downward.)
- **Right mouse button** - Translate x and y coordinates.
4. Adjust the isosurface Level to 680 by moving the Isosurface Level slider. This will create a new model of the vesicle, which more closely follows the contours of the outer surface of the membrane.

5. Change the color of the isosurface by selecting the Color tab in the lower left half of the render window. This will also change the color the object in
the EM3D visualization window. Set **Red** = 128, **Green** = 128, **Blue** = 255. Press **Apply**.

![Image of EM3D visualization window]

**Figure 40:** Changing Isosurface color (object rotated)

### 8.5 Automatic isolated segmentation

Automatic, isolated segmentation is used for objects such as membranes and filaments. For example, segment the synthetic, rod-like filament connecting the lower left to the upper right vesicle.

1. In the Segmentation window, select **Objects > New object**.

2. Name the filament **Filament 1**.

3. Select the **Isolated** radio button.

4. Navigate to slice 66 in the **EM3D visualization window**.

5. **Zoom** into the image by 250%.

![Images showing filament segmentation]

**Figure 41:** Isolated anchor: a) anchor line, b) searched, c) maximum gray reduced, and d) Segmented.

6. Leave the **Surface width** and **smoothing** sliders at their default values.

7. Press the **Propagate** button (Figure 42).
8. Examine the segmentation in the EM3D visualization window.

9. If you are unsatisfied with the segmentation try the following techniques

   • Adjust the start / stop slice for the propagation and re-propagate.
   • Adjust individual segmentation lines by pressing the middle mouse button over the segmented filament.

   The following message will appear:

   ![Question dialog box]

   • Select Yes.
   • The yellow anchor line will reappear for the object. Adjust the anchor line and press Segment.
   • Repeat for all slices that need adjusting.

10. When satisfied with the segmentation, render the filament.

11. Rendering isolated segmentation

1. Open the Render window.

2. Filament will be displayed in red in the object list.

4. Press the **Home** button on the top of the panel, so you can see both objects.

5. Adjust the isosurface level until the filament is well fit.

6. Make the color of the filament gold using Red = 255, Green = 192, Blue = 64.

![Figure 43: Rendering of vesicle 1 and isolated filament](image)

### 8.6 Automatic pinned segmentation

The endpoints of a pinned object occur in same x,y position throughout all the slices. This type of segmentation works well for objects like the membrane in our synthetic dataset.

1. In the **EM3D visualization window** press the **Home** button adjacent to the **Zoom** list.

2. In the **Segmentation Window** select **Objects > New Object**.

3. Name the object **Membrane**.

4. Select **Pinned** segmentation.
5. Use the middle mouse button to select points for the anchor, and the right mouse button to remove points from the anchor line.

6. Press Search.

7. Reduce the Maximum gray value.

8. Press Segment.


![Propagated pinned segmentation](image)

**Figure 44: Propagated pinned segmentation**

### 8.7 Render pinned segmentation

1. Open the Render window.

   The Membrane will be displayed in red in the Object list.

2. Select Membrane and press Enable.

3. Press the Home button on the top of the panel, so you can see all of the objects.

   Notice that the rendering time has increased. This is caused by the number of polygons in the membrane. In order to reduce the rendering time, decimate the membrane surface.

   With membrane highlighted in the Object list, move the Surface Decimation slider to 3 under the Main tab.

4. Adjust the isosurface level until the membrane is well fit.

5. Change the color of the membrane to bright gray using Red = 192, Green = 192, Blue = 192.
8.8 Strategies for adjusting automatic segmentations

8.8.1 Setting the start/stop slice

If the segmentation propagates beyond the edge of the object, then use the Start Slice and Stop Slice sliders to identify the range of the object.

8.8.2 Adjust minimum/maximum gray value

Usually it is a good idea to reduce the Maximum gray value to only include values that correspond to the stained object. This helps the algorithm follow the line of interest and not get attracted to noise.

8.8.3 Smoothing

The smoothing slider determines how fast the curve can deviate. By increasing the smoothing value, you can reduce the likelihood of wild fluctuations in the anchor line. Conversely if you have a shape that is changing rapidly, you will need to reduce the smoothing to allow the anchor line more flexibility.

8.8.4 Adjusting the anchor line and re-propagating

Often segmentation will propagate smoothly for many slices, but then begin to deviate, especially with convoluted membranes. A good way to approach such a situation is to allow the object to propagate.

1. Scroll through the slices to where the segmentation begins to deviate.

2. Right click the mouse button to move into adjust mode.

3. Adjust the anchor line.
4. Press Segment.

Depending on direction you want to propagate set the Start or Stop slice to the current value.

5. Press Propagate.

Example: Initial Reference slice is 50. The segmentation starts to go awry at 60. Adjust the segmentation on slice 60 and set the Start Slice to 60. Press Propagate.

8.8.5 Using a thinner search width

When objects with similar gray scale are adjacent it is often a good idea to use a smaller search width when propagating the segmentation. This will help the algorithm stay in the desired object. After the propagation is complete increase the width to include the entire object.

8.9 Manual segmentation

When structural components have a complex topology or are too noisy for automatic segmentation, it is necessary to perform a manual segmentation. In manual segmentation, the goal is to literally define the boundaries of a VOI that encloses the structural component. In the following section a manual segmentation will be performed for the small filament that connects the two vesicles on the right-hand side of the reconstructed Synthetic volume.

1. File > New Object.

2. Select the Manual tab.

3. Name the object Filament 2.

4. In the EM3D visualization window navigate to slice 70.

5. Zoom 300% and center Filament 2 in the window.

6. This time instead of drawing an anchor line in the center of the object we are going to draw a closed path around the object.

Be sure to include the entire object inside the path, because only objects inside the outline will be considered.

7. Select the Piecewise radio button. Piecewise interpolation connects the anchor points with straight lines; whereas, Spline interpolation connects the anchor points with smooth curves (Figure a).

8. Use the middle mouse button to define anchor points, creating a closed path around the object. (Points can be removed by pressing the right mouse button). Only a few points are necessary.
9. Press the **Segment** button. The interior of the volume is now marked with a red overlay and the anchor path turns green (Figure ). All points in the interior on this slice have now been added to the VOI for this object.

10. Press the **Up** button to move to the next slice. The same anchor points that were defined on the previous slice appear and can be edited using the mouse as usual.

11. When satisfied with the anchor path, press the Up button again.

   > Pressing the Up or Down button is equivalent to pressing the Segment button and moving the slider one slice.

12. At the topmost slice containing the object, select **Segment**.

13. Return to the 1st slice segmented (70) using the **visualization window Navigation Tools**; **NOT** the **Down** button.

14. Navigate down one slice, using the **visualization window Navigation Tools**; **NOT** the **Down** button. From here repeat steps 7 and 8 using the **Down** button to segment the lower half of the object.

15. Continue editing points as necessary (little editing will be necessary for this simple object) and pressing the Down button until the lowest slice containing the object is reached; select **Segment** again. This completes the manual segmentation of this object.

### 8.10 Rendering a manually segmented object

1. Open the Render window.

2. **Filament** will be displayed in red in the **Objects** window until enabled.

3. Select **Filament 2** and press **Enable**.

4. Adjust the isosurface level until the filament is well fit.
5. Make the color of the filament gold using Red = 255, Green = 192, Blue = 64.

8.11 Working with groups and regions

Sets of logically related objects can be collected into named groups and/or regions for convenience.

These are the steps to create a group:

1. In the Rendering Window, select “Filament1” and “Filament2” from the Objects list. Then select File>Group. A window will open to enter a name for the new group.

2. Name the new group “Filaments”.

3. The new group will be listed in the Groups List under the Groups tab.

4. Whenever a group is selected, all of its corresponding members will be selected in the Objects list. This permits convenient adjustment of color, visibility, or for the calculations as described in the next chapter.

Regions are not yet implemented in this version of EM3D.
8.12 Advanced Rendering

The EM3D Manual contains information about more advanced features available in the Render window. Some of these features are described in the next Section 8, Calculations. Other affects worth exploring can be made in the Effects header menu.
9 Calculations

9.1 Spatial uncertainty

Spatial uncertainty is a measure of the reliability of the isosurface models. EM3D estimates the spatial uncertainty by calculating the gradient scale length, \( l \), in the vicinity of each vertex of the model. The scale length is measured, specifically, along the outward normal of the model vertex. This is a measure of how rapidly the gray level is changing as one moves away from the model surface at that point—a measure of the sharpness of the contrast boundary. This measure is combined with an estimate of grayscale uncertainty, \( \sigma_g \), to convert grayscale uncertainty to spatial uncertainty: \( \sigma_n = l / \sigma_g \).

**Summary:**
1. Enable segmented object(s).
2. Select the Uncertainty tab.
3. Push the Calculate button.
4. Examine the results histogram and readouts in nm scale.

9.2 Thickness

The Thickness tab controls thickness calculation of the selected surface model objects.

1. Open the EM3D Rendering window and select the **Thickness** tab.
2. Choose one-or-more models for the calculation by selecting from the Objects list. For example, select “Filament 1” and “Filament 2”.

   *It takes a very long time to perform calculations for the “Presynaptic membrane” or the “Vesicle 1”. Increase the surface decimation when calculating the thickness of these models.*

3. Press the **Calculate** button. A Status window will open to indicate the progress of the calculation. As the thickness calculation for each object is completed, its histogram and statistical information will appear for each model as it is selected.

4. Select Filament 1 and examine the results histogram. Adjust **Min** and **Max** to eliminate outliers. For the thickness calculation of Filament 1 adjust Max to about 27. The median thickness of Filament 1 is about 6.25 nm and the mean thickness is 8.12 nm. Check the Overlay checkbox, if not already checked and see the color overlay in the render display of Filament 1.
9.3 Proximity

The Proximity tab in the Rendering Window controls the calculation of proximity between the selected objects in the Object list and the Reference object. These calculations require that one object be designated as a reference, while one-or-more models be designated as destinations. The Proximity values are the distance between each destination vertex and the vertex closest to it on the reference object.

Summary:

1. Open Rendering window and select the Proximity tab.
2. Select one-or-more objects and/or regions in their respective lists.
3. Push the Calculate button.
4. Examine the results histogram.

1. Open the EM3D Rendering window and select the Proximity tab.
2. Select object(s) and/or regions and press the Destination button. For example select Filament 1.
3. Press the Calculate button. The distances from each vertex of Filament 2 and vertex closest to it in Filament 1 is calculated.
4. Examine the results in the histogram. The mean distance between Filament 1 and 2 is about 24 nm.
10 Appendix

10.1 Acknowledgments

We would like to acknowledge the following groups whose code is used in this program or has provided inspiration:

**Paul Bourke**
Algorithm from "Polygonising a scalar field" by Paul Bourke

**Takuya Ooura**
"General Purpose FFT (Fast Fourier/Cosine/Sine Transform) Package"
[http://momonga.t.u-tokyo.ac.jp/~ooura/fft.html](http://momonga.t.u-tokyo.ac.jp/~ooura/fft.html)

**Lee Thomason and Yves Berquin**
"TinyXml"
[http://sourceforge.net/projects/tinyxml](http://sourceforge.net/projects/tinyxml)

**LAPACK**
Linear Algebra PACKage
[http://www.netlib.org/lapack](http://www.netlib.org/lapack)

**Fautré, Tanguy**
Tri stripper code, used to tessellate the 3D models

**Ken Martin, Will Schroeder, and Bill Lorensen**
vtkThinPlateSplineTransform algorithm from "VTK"
Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen

All rights reserved.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS `AS IS` AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHORS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
10.2 Glossary

CCD: A Charge Coupled Device is made up of semiconductors arranged in such a way that the electric charge output of one semiconductor charges an adjacent one. A CCD camera, for instance, is used to acquire images.

Cumulative Distribution Function (CDF): The probability that a gray value is less than or equal to X.

\[ F(x) = \sum_{i=0}^{X} f(i) \]

Decimation: The image or volume size reduction expressed as a log2 exponent, so a decimation of 0 means no decimation, full resolution. A decimation of 1 is 1/2, decimation of 2 is 1/22 or 1/4, decimation of 3 is 1/23 or 1/8, etc.

Fiducial Markers: also referred to as fiducials, colloidal gold beads placed on the surface of the TEM sample or incorporated into the sample used to align the projections.

Intersection: Equivalent to Logical AND, meaning that a point is not added to the new region unless all selected VOI’s exist at that point.

Invert: Invert the gray scale of an image to create a negative image.

Isosurface/isodensity: A region or surface in which the image gray scale is the same, similar to topographic lines on a map.

Projections: Electron micrographs of the individual tilts in the dataset used to reconstruct a 3D volume.

Radio Buttons: A group of buttons in which exactly one button is selected at a time.

Signal-to-Noise Ratio: The ratio between ‘signal’, the desired quantity measured by an image, to the ‘noise,’ the random variations in that quantity. In EM tomography, the signal is usually the contrast between a structural component and its adjacent background, while the noise is a complex function of the EM projection image formation and subsequent tomographic processing steps, so SNR is usually estimated empirically from the standard deviation of a relatively uniform background portion of the reconstructed volume.

Slices: These are the 2D images that are virtually sliced (interpolated) from the reconstructed volume.

Tessellation: Creation of small triangles that represent a surface for use in surface rendering.

Transverse: The 2 orthogonal views to the x,y plane – the (x,z) and (z,y) planes.

Topology: Properties of geometric figures or solids that are not changed by stretching or bending. Donuts and picture frames have equivalent topologies.

Twist Angle: The rotation of the projection tilt axis about the depth axis.

Union: The logical OR of two or more objects, i.e. considered true if any object lies in the space.

Vertex: A point in 3D space that defines a corner of one or more polygons.

Volume of interest: A subset of the volume containing defined by the user or an object.

Voxel: Short for volume-pixel element, the smallest distinguishable cube in a three-dimensional image.

10.3 Acronyms

- CCD: Charged-Coupled Device
- CDF: Cumulative Distribution Function
- MIP: Maximum Intensity Projection
- MPEG: Moving Pictures Experts Group, digital video format
- MRC stack: Medical Research Council format used to output dataset from the microscope
• nm: nanometer 1x10^-9 m
• RMS: root mean square
• SNR: signal to noise ratio
• TEM: Transmission Electron Microscope
• TIFF: Tagged Image File Format
• VOI: Volume of Interest

10.4 Table of Figures

Figure 1: Raw, unaligned EM projection images .............. 8
Figure 2: Aligned projections ........................................... 9
Figure 3: Reconstruction.................................................... 9
Figure 4: Segmentation of a synthetic synaptic vesicle ....... 9
Figure 5: Surface model of a synthetic synaptic vesicle (blue), presynaptic membrane (gray) and two filaments (yellow) ............ 10
Figure 6: Windows Install Wizard................................. 12
Figure 7: Select program location .............................. 12
Figure 8: Dataset import window ............................... 15
Figure 9: Projections in visualization window............. 16
Figure 10: Measuring tool ........................................... 17
Figure 11: Image Scaling ............................................. 18
Figure 12: Review Control .......................................... 19
Figure 13: Projection Alignment window .................. 20
Figure 14: Display Markers with Threshold set at an appropriate value of 0.35 (left) and too high a value of 0.50 (right)...................... 21
Figure 15: Twist Angle Lock........................................ 22
Figure 16: Alignment after using automatic alignment ....... 22
Figure 17: Results of refined Automatic Alignment .......... 23
Figure 18: XY display of slices 40, 75, 110, 128, 149, 180, 216, 27
Figure 19: Reconstruction window .............................. 28
Figure 20: Reconstructed volume, 2:1 decimation (Decimate = 2) 29
Figure 21: Reconstruction control for thick, decimated volume 30
Figure 22: Thick, decimated reconstruction ................. 30
Figure 23: Reconstruction Control after adjusting center and thickness 31

Figure 24: Volume visualization window mode ....................... 33

Figure 25: Dual Combine .................................................. 38

Figure 26: Auto Indexed .................................................. 39

Figure 27: False fiducial markers (left) and correct fiducial markers (right) 40

Figure 28: Sorted by volume A slice location ..................... 40

Figure 29: Sorted by reverse distance .............................. 41

Figure 30: Segmentation Window ...................................... 47

Figure 31: Segmentation File Menu .................................. 48

Figure 32: Initial segmentation anchor ............................. 49

Figure 33: Outlined, Searched area, Reduced Maximum Gray value, and segmented center slice of Vesicle 1........................................... 50

Figure 34: Initial propagated segmentation of vesicle ....... 50

Figure 35: Propagated segmentation with artifact-induced error (left) and after adjustment (right) ................................................. 50

Figure 36: Process menu on EM3D visualization window Menu 51

Figure 37: Render window ................................................. 52

10.5 Some RGB color combinations

<table>
<thead>
<tr>
<th>Color</th>
<th>Red</th>
<th>Green</th>
<th>Blue</th>
</tr>
</thead>
<tbody>
<tr>
<td>White</td>
<td>255</td>
<td>255</td>
<td>255</td>
</tr>
<tr>
<td>Black</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Gray</td>
<td>128</td>
<td>128</td>
<td>128</td>
</tr>
<tr>
<td>Red</td>
<td>255</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Green</td>
<td>0</td>
<td>255</td>
<td>0</td>
</tr>
<tr>
<td>Blue</td>
<td>0</td>
<td>0</td>
<td>255</td>
</tr>
<tr>
<td>Yellow</td>
<td>255</td>
<td>255</td>
<td>0</td>
</tr>
<tr>
<td>Magenta</td>
<td>255</td>
<td>0</td>
<td>255</td>
</tr>
<tr>
<td>Cyan</td>
<td>0</td>
<td>255</td>
<td>255</td>
</tr>
<tr>
<td>Periwinkle</td>
<td>128</td>
<td>128</td>
<td>255</td>
</tr>
<tr>
<td>Color</td>
<td>R</td>
<td>G</td>
<td>B</td>
</tr>
<tr>
<td>-----------</td>
<td>----</td>
<td>----</td>
<td>----</td>
</tr>
<tr>
<td>Gold</td>
<td>255</td>
<td>192</td>
<td>64</td>
</tr>
<tr>
<td>Lime</td>
<td>128</td>
<td>255</td>
<td>128</td>
</tr>
<tr>
<td>Salmon</td>
<td>255</td>
<td>128</td>
<td>128</td>
</tr>
<tr>
<td>Hot Pink</td>
<td>255</td>
<td>64</td>
<td>192</td>
</tr>
<tr>
<td>Neon Green</td>
<td>192</td>
<td>255</td>
<td>64</td>
</tr>
<tr>
<td>Purple</td>
<td>192</td>
<td>64</td>
<td>255</td>
</tr>
<tr>
<td>Turquoise</td>
<td>64</td>
<td>192</td>
<td>255</td>
</tr>
<tr>
<td>Mint</td>
<td>64</td>
<td>255</td>
<td>192</td>
</tr>
</tbody>
</table>